(solved)Teleportation not working

View previous topic View next topic Go down

(solved)Teleportation not working

Post by Rhino.Freak on 29th August 2012, 4:32 pm

State 400 & 401 are not working as they should, what happens is that i want my attack to appear right beneath enemy and hit, for that i added dvx: 60 after the invisible frame of state 400 ( i read some where that we appear 60 pixels away) but it just appears away . Pls help me Sad

Frames:

Character:
Code:

<frame> 318 forest
  pic: 50 state: 15 wait: 2 next: 319 dvx: 0  dvy: 0  centerx: 39  centery: 79  hit_a: 0  hit_d: 0  hit_j: 0
  wpoint:
      kind: 1  x: 39 y: -999 weaponact: 21  attacking: 0  cover: 1  dvx: 0  dvy: 0  dvz: 0
  wpoint_end:
  bdy:
      kind: 0  x: 29  y: 15  w: 28  h: 64
  bdy_end:
  bdy:
      kind: 0  x: 21  y: 80000  w: 43  h: 62
  bdy_end:
<frame_end>
<frame> 319 forest
  pic: 45 state: 15 wait: 1 next: 320 dvx: 0  dvy: 0  centerx: 39  centery: 79  hit_a: 0  hit_d: 0  hit_j: 0
  wpoint:
      kind: 1  x: 39 y: -999 weaponact: 21  attacking: 0  cover: 1  dvx: 0  dvy: 0  dvz: 0
  wpoint_end:
  bdy:
      kind: 0  x: 29  y: 15  w: 28  h: 64
  bdy_end:
  bdy:
      kind: 0  x: 21  y: 80000  w: 43  h: 62
  bdy_end:
<frame_end>
<frame> 320 forest
  pic: 46 state: 15 wait: 0 next: 321 dvx: 0  dvy: 0  centerx: 39  centery: 79  hit_a: 0  hit_d: 0  hit_j: 0
 sound: data\007.wav   
wpoint:
      kind: 1  x: 39 y: -999 weaponact: 21  attacking: 0  cover: 1  dvx: 0  dvy: 0  dvz: 0
  wpoint_end:
  bdy:
      kind: 0  x: 29  y: 15  w: 28  h: 64
  bdy_end:
<frame_end>
<frame> 321 forest
  pic: 46 state: 15 wait: 0 next: 322 dvx: 0  dvy: 0  centerx: 39  centery: 79  hit_a: 0  hit_d: 0  hit_j: 0
 sound: data\SNDDATA_2943.wav     
wpoint:
      kind: 1  x: 39 y: -999 weaponact: 21  attacking: 0  cover: 1  dvx: 0  dvy: 0  dvz: 0
  wpoint_end:
  bdy:
      kind: 0  x: 29  y: 15  w: 28  h: 64
  bdy_end:
  opoint:
      kind: 1  x: 350 y: 100 action: 74 dvx: 0 dvy: 0 dvz: 0 oid: 417 facing: 0
  opoint_end:
  bdy:
      kind: 0  x: 21  y: 80000  w: 43  h: 62
  bdy_end:
<frame_end>
<frame> 322 forest
  pic: 46 state: 15 wait: 10 next: 999 dvx: 0  dvy: 0  centerx: 39  centery: 79  hit_a: 0  hit_d: 0  hit_j: 0
    sound: data\063.wav
wpoint:
      kind: 1  x: 39 y: -999 weaponact: 21  attacking: 0  cover: 1  dvx: 0  dvy: 0  dvz: 0
  wpoint_end:
  bdy:
      kind: 0  x: 29  y: 15  w: 28  h: 64
  bdy_end:
  bdy:
      kind: 0  x: 21  y: 80000  w: 43  h: 62
  bdy_end:
<frame_end>

Opointed Object :

Code:

<frame> 74 tree_begin_attack
  pic: 999 state: 400 wait: 0 next: 75 dvx: 0 dvy: 0 dvz: 0 centerx: 145 centery: 250 hit_a: 0 hit_d: 0 hit_j: 0
<frame_end>
<frame> 75 tree_begin_attack
  pic: 999 state: 3006 wait: 0 next: 76 dvx: 0 dvy: 0 dvz: 0 centerx: 145 centery: 250 hit_a: 0 hit_d: 0 hit_j: 0
<frame_end>
<frame> 76 tree_begin_attack
  pic: 9 state: 3006 wait: 1 next: 77 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
    sound: data\036.wav
<frame_end>
<frame> 77 tree_begin
  pic: 10 state: 3006 wait: 1 next: 78 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
<frame_end>
<frame> 78 tree_begin
  pic: 11 state: 3006 wait: 1 next: 79 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
  itr:
  kind: 0 x: 110 y: 160 w: 60 h: 90 vrest: 1 fall: 30 injury: 40
  itr_end:
<frame_end>
<frame> 79 tree_begin
  pic: 12 state: 3006 wait: 1 next: 80 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
  itr:
  kind: 0 x: 110 y: 137 w: 60 h: 100 dvx: 110 dvy: -60 vrest: 1 fall: 30 injury: 50
  itr_end:
<frame_end>
<frame> 80 tree_begin
  pic: 13 state: 3006 wait: 1 next: 81 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
  itr:
  kind: 0 x: 110 y: 90 w: 60 h: 110 dvx: 110 dvy: -60 vrest: 1 fall: 30 injury: 70
  itr_end:
<frame_end>
<frame> 81 tree_begin
  pic: 14 state: 3006 wait: 1 next: 70 dvx: 550 dvy: 0  centerx: 145 centery: 250 hit_a: 0  hit_d: 0  hit_j: 0
<frame_end>

problem is in this part only.. if im too close to opponent, the tree appears faar away.. if im facing otherside it appears other way.. Mad

sorry i didnt had done the dvx: 60 thing..


Last edited by Rhino.Freak on 2nd September 2012, 8:23 am; edited 2 times in total

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by A-MAN on 29th August 2012, 6:03 pm

Can you please show us the attack frames?
avatar
A-MAN
Revolutionary Army
Revolutionary Army

A-MAN : Team A Leader
Posts : 2690
Reputation : 347
Bellies Bellies : 18841
Online
Offline


View user profile http://onepiecea-edition.yourme.net

Back to top Go down

Re: (solved)Teleportation not working

Post by Rhino.Freak on 29th August 2012, 6:42 pm

Ill post them tommorow..

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by -|Mark975|- on 30th August 2012, 9:13 am

You always say that, lol :p .

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►


avatar
-|Mark975|-
Legendary Pirate
Legendary Pirate

-|Mark975|- : Team A Spriter and Designer
Posts : 1312
Reputation : 211
Bellies Bellies : 16023
Online
Offline


View user profile

Back to top Go down

Re: (solved)Teleportation not working

Post by Rhino.Freak on 31st August 2012, 5:29 am

~ updated!

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by A-MAN on 31st August 2012, 8:34 am

Ehm.. Thats probably because state 400 doesn't work with wait: 0. Try changing that wait: 0 to wait: 1 then tell me the results.
avatar
A-MAN
Revolutionary Army
Revolutionary Army

A-MAN : Team A Leader
Posts : 2690
Reputation : 347
Bellies Bellies : 18841
Online
Offline


View user profile http://onepiecea-edition.yourme.net

Back to top Go down

Re: (solved)Teleportation not working

Post by Rhino.Freak on 31st August 2012, 4:20 pm

Did it, not working.. :/

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by A-MAN on 31st August 2012, 4:29 pm

Ehm, just one question. It doesn't teleport to the enemy at all. Or it does teleport to the enemy but not right under him? If its that, then make sure that the frame with the dvx isn't the one with state 400, and also the wait value must be 1. Or you can keep it as wait:0 and change the dvx to 120 (not 60).
avatar
A-MAN
Revolutionary Army
Revolutionary Army

A-MAN : Team A Leader
Posts : 2690
Reputation : 347
Bellies Bellies : 18841
Online
Offline


View user profile http://onepiecea-edition.yourme.net

Back to top Go down

Re: (solved)Teleportation not working

Post by Rhino.Freak on 1st September 2012, 5:03 am

What happens is the tree appears a certain distance away from enemy everytime..ill try what you say and post a screenshot

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by Rhino.Freak on 2nd September 2012, 8:16 am

Sorry for double post, but its working now!! :)all hail A-MAN XD

◄∞▐▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▌∞►



'The Monster inside me is growing bigger!' *Munch-munch, chomp-chomp, gobble-gobble, gulp*
avatar
Rhino.Freak
Revolutionary Army
Revolutionary Army

Rhino.Freak - Team A Coder
Posts : 3552
Reputation : 274
Bellies Bellies : 17445
Online
Offline


View user profile http://pokegames.forumotion.com

Back to top Go down

Re: (solved)Teleportation not working

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum